Live Support

RE: mac 10.5.8

i have mac 10.5.8 does this mean i cant use the course? Mine also will not load and my mac says i dont need any software updates at this time..

  • That is correct. Unfortunately, Apple no longer supports the necessary security updates to run Java on computers with Mac OS 10.5.x.  You must have Mac OS 10.6, 10.7 or 10.8.  Please email customer service directly (elearning@ncsbn.org) if you need to request a refund.